How to find VDI Client (ThinClient) MAC address from Horizon View

 

      While administering VDI environments, most of the time we will struggle to get Thin Client or VDI Client MAC address for troubleshooting, re-imaging or for providing remote shadow support. Below article explains about a simple “visual basic” script to get this information. In my case, I kept this script on network share and configured a Desktop shortcut on all VDI machines.
       When a user connects or reconnects to a View desktop, Horizon Client gathers information about the client system and View Connection Server sends that information to the remote desktop.
       View Agent writes the client computer information to the system registry path “HKEY_CURRENT_USER\Volatile Environment” on VDI desktops.
Registry values:
 
ViewClient_MAC_Address
ViewClient_IP_Address
Below script will read the HKEY_CURRENT_USER\Volatile Environment\ViewClient_MAC_Address registry parameter and will give Visual Basic output as below screenshot.

”#### VBS Script ####”
On Error Resume Next
Dim objShell, strTemp
Set objShell = WScript.CreateObject(“WScript.Shell”)
strTemp = “HKEY_CURRENT_USER\Volatile Environment\ViewClient_MAC_Address”
WScript.Echo “VDI Client MAC Address : ” & objShell.RegRead(strTemp) 
”### END ####”

You might be interested in …

How to Change Workspace ONE Access SAML Signing Certificate

VMware, Workspace ONE Access

In my previous engagement, a customer asked to change the Workspace ONE Access SAML signing cert after a year and a half in production.  WS1 Access was fully deployed along with DR sites and configured as 3rd party IDP with ADFS for O365 use cases. Background: SAML signing certificates ensure that messages are coming from […]

Read More

VMware PowerCLI Connect-VIServer Error: Invalid server certificate. Use Set-PowerCLIConfiguration

VMware

    Problem:   Unable to connect vCenter with  “Connect-VIServer” command. It gives error “VMware PowerCLI Connect-VIServer Error: Invalid server certificate. Use Set-PowerCLIConfiguration“       Reason:   The issue usually happen whenever Self Signed Certificate is used in Vcenter server.     Solution:   Execute below command to ignore Certificate check during vCenter Connection. […]

Read More

Unified Access Gateway with Microsoft Azure AD Integration using SAML

Many customers are moving towards extending their Datacenter workloads to the clouds, and Microsoft Azure is one of the partners that the VMware EUC team works very closely with. VMWare Unified Access Gateway, what we called “UAG,” is available in the Azure AD app gallery directly, reducing and simplifying the efforts of integration and configurations.  […]

Read More

Leave a Reply

Your email address will not be published. Required fields are marked *